Webconnector ReceiveResponseXML Failed

Alisha shared this problem 5 years ago
Solved

I'm getting this message with Webconnector. Nothing from last night has been added into QB.


Version:

PHP QuickBooks SOAP Server v2.0 at /qbint/io_qbserver.php


Message:

ReceiveResponseXML failed


Description:

QBWC1042: ReceiveResponseXML failed

Error message: Response is not well-formed XML. See QWCLog for more details. Remember to turn logging on.

Best Answer
photo

The only errors I am seeing are that you've deleted certain invoices in QB and IO cannot then add payments for those. Looking at your log at Settings->QuickBooks->View Log, it appears to be entering your data as it should.

Comments (10)

photo
1

The only errors I am seeing are that you've deleted certain invoices in QB and IO cannot then add payments for those. Looking at your log at Settings->QuickBooks->View Log, it appears to be entering your data as it should.

photo
1

I didn't know this list was there. Do I need to go back through all of the items going back as far as this weekend or does the list repeat each time Webconnector tries to import?


I can say lead 230567 shows it was deleted in QB, but not from the current file location Webconnector is updating to. My current QB file and IO match exactly so there should not be any errors with that particular lead. I have not yet gone through the other ones but I did delete the invoices in the old QB file that I'm no longer using for Webconnector.

photo
1

If you changed the location of your QB file you have to delete the entry from the Web Connector and re-add it by clicking Download on the IO Quickbooks page. It has been trying to update the old file.


It will normally re-try the failed ones, but in this case since it thinks they were deleted I do not think it will re-try them. I would make a list of the lead ID's you see that have errors, then after updating the Web Connector with the new file, let it run for a day until it is all caught up. Then go through and manually fix those leads in QB if needed.

photo
1

So, Jack, are you saying when I delete my old QB file, I'm going to have hundreds more errors? Why would it be trying to do anything with my old QB file when I changed the location in IO to view only the new location?


How do I delete the entries from Webconnector? I went to the QB link in IO and I don't see what you mean by clicking download. I see the download link to download Webconnector.

photo
1

Yes you need to go to Web Connector and delete the InflatableOffice entry, then go to InflatableOffice->Quickbooks and on step 4 click download and follow the rest of the instructions. Updating the QB file location in InflatableOffice doesn't do anything unless you re-set it up through the web connector.

photo
1

I think you are under the impression that I don't have Webconnector correctly set up. I do and since I have used the new QB file, I have had to compare files because IO didn't correctly transfer all of the data over to the new file.


I did un-install and reinstall yesterday a couple times thinking the issue was me but each time I reinstalled Webconnector, the messages were still there. I will retry it again and see if it works.

photo
1

I have un installed and re installed the program and I'm still getting the same error.

photo
1

You'll have to call in and setup a remote session with us.

photo
2

I removed all of the payments, put each lead to quote and after it updated, I readded the payments and completed the events. The items imported.

photo
1

Good!