Quote Request </form> Changing Position

Casey Perno shared this problem 4 years ago
Solved

Hi team,


I've done some remodeling to the Quote Request page and I have it deployed in an iframe. For some reason though, the </form> tag keeps jumping up a few lines, above the <input type="hidden"...> section and above the submit button. This prevents the submit button from actually doing anything.


I thought it only did it when I opened up the html to edit it, which was fine because I would just fix it manually, but I had it working fine one night and it was broke the next morning. This leads me to believe it is automatically jumping up in the HTML layout? And I have no idea what's causing it or how to fix it.


Thanks!

Best Answer
photo

I checked your page and it looks like you have it working correctly now. I've seen the html editor do some strange things sometimes when the html inside has errors in it. It will move, add, or remove things to attempt to correct it. The best way to prevent is to write well formed html inside the editor.

Comments (2)

photo
1

I checked your page and it looks like you have it working correctly now. I've seen the html editor do some strange things sometimes when the html inside has errors in it. It will move, add, or remove things to attempt to correct it. The best way to prevent is to write well formed html inside the editor.

photo
1

I just combed through it again using Sublime Text. Looks like I was missing a </div> towards the end which was apparently causing the </form> to jump up to complete the circuit (for lack of a better phrase).


If you don't hear back from me, it's been resolved! If it jumps again, I'll let you know. Cheers!