Contract *signature* Formatting

Casey Perno shared this question 4 years ago
Answered

The upgrades to the digital signature have inspired me to revisit how my contract template handles it. Unfortunately, it seems *signature* adds unwanted styling effects. Namely, significant margins above and to the left of the rendered IP address. Has this always been the case and I just didn't notice before? Is there a way around this? Or has it be depreciated for *contract_printedname* and *contract_signedtime*?


*Contract_printedname* and *contract_signedtime* also don't show up right away. It seems to require you to come back to the contract to view it. This isn't a problem necessarily but may be a bug or something I'm doing wrong/not noticing.


Furthermore, what exactly is the function of *contract_signature*? I tested it once and just got a long string of random characters.


Thanks again for this major update!

Best Answer
photo

*signature*, *signeddate*, *initials*, and *printed_name* are the correct variables to use for contract signatures in your contract templates.


The variables *contract_signature*, *contract_signedtime*, and *contract_printedname* are what you would use to access these fields in documents other than inside contracts. For instance if you wanted to put this information in an email to a customer.

https://www.inflatableoffice.com/include/variables.php


In regard to the characters, I've fixed that issue.

Comments (8)

photo
1

*signature*, *signeddate*, *initials*, and *printed_name* are the correct variables to use for contract signatures in your contract templates.


The variables *contract_signature*, *contract_signedtime*, and *contract_printedname* are what you would use to access these fields in documents other than inside contracts. For instance if you wanted to put this information in an email to a customer.

https://www.inflatableoffice.com/include/variables.php


In regard to the characters, I've fixed that issue.

photo
1

It doesn't seem like any of them are working for me now, even in the original template. I'll fiddle with it again tomorrow morning and report back.


  • I'm not sure what you mean by going back to the contract to view the printed name and signed time. Could you give me steps to reproduce?

Open Contract, Sign Contract. No signature or name or date is shown on the actual contract. Shows up fine in top left part of screen. Close Contract Page, reload lead, view contract. Shows the new info fine (at least it was before it stopped working entirely! lol). Like I said, not really a bug. I just thought it always showed up right away. I'm probably misaken.

photo
1

Here is a screen shot of what I was trying to describe from *contract_signature*


uoOLC5M2V02VV3BC2HAX


Here is what it reads:

  1. image/svg+xml;base64,PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiIHN0YW5kYWxvbmU9Im5vIj8+PCFET0NUWVBFIHN2ZyBQVUJMSUMgIi0vL1czQy8vRFREIFNWRyAxLjEvL0VOIiAiaHR0cDovL3d3dy53My5vcmcvR3JhcGhpY3MvU1ZHLzEuMS9EVEQvc3ZnMTEuZHRkIj48c3ZnIHhtbG5zPSJodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZyIgdmVyc2lvbj0iMS4xIiB3aWR0aD0iMCIgaGVpZ2h0PSIwIj48L3N2Zz4=

If you make a contract, sign it, delete it, then make a new one, this shows up. It doesn't seem to show up if you don't delete the original. I don't know how many people will run into this issue outside of testing, but I figured I'd point it out anyway.


Other than this bug, I still can't seem to get any of the contract variables to display anything. Will keep you posted!

photo
1

I'm sorry Casey. I told you the wrong information. I'm going to update the official answer to be correct.

photo
1

InflatableOffice wrote:

I'm sorry Casey. I told you the wrong information. I'm going to update the official answer to be correct.
Thanks for the update! Unfortunately, and I feel terrible that I keep breaking this, but now my tests won't even let me sign the contract at all. Before when I clicked sign, it would not show anything on the physical contract, but would be fine in the back end, and display as complete on the top left. Now it won't even register as signed at all (which, needless to say, is a big problem).

photo
1

This is going to sound like a bad break up line, but it's not you, it's me. We made a bug fix to your issue that caused another one. It's fixed now.

photo
1

InflatableOffice wrote:

This is going to sound like a bad break up line, but it's not you, it's me. We made a bug fix to your issue that caused another one. It's fixed now.
I can sign again! I'm also getting the proper functionality for *signature*, *signeddate*, and *printed_name*, like you said in the official answer. Graci.


But now I'm back to the original question: Why am I getting a significant white space added to the top (and slightly less to the left) of *signature* when signed?


Edit: I went back to find examples of what I'm talking about and now *signature* is displaying something different than it was before... but the styling is gone! You guys playing with variables on me? =P

photo
1

This release was large and so we are continually making updates to it behind the scenes to get it working the way we want. From your edit it sounds like it's working the way you want. Thanks.